What happened?

We released a hotfix for Wise-Sync (v4.6.4.1) on the 29th March 2019, to provide support for ConnectWise v2019.3. We had reports from customers that were experiencing errors during sync:


  • Error Updating Xero: Failed to get product by item id  'xxxxxx'
  • Error Updating Xero: Sequence contains no elements
  • Validation Error: No matches for billing or default contact.


What have we done about it?

29 March 2019

Due to the impact this had on our customer base, we rolled back this hotfix.


This means we cannot support ConnectWise v2019.3 until these issues are resolved.


The hotfix was thoroughly tested on our testing environment prior to release and on repeat of those tests, we can verify that the issues don't exist in our testing environment. We are logging a ticket with ConnectWise to see if this is an issue at their end.


We understand that it is the end of the month however we're continuing to investigate this problem and will provide updates where we have them.


Update 1st April 2019

We've logged a support ticket with ConnectWise relating to the issues experienced with changes made to v2019.3, resulting in breaking changes on prior versions. The decision to rollback was made to support the vast number of partners that are impacted (and still on GA Version 2019.2). ConnectWise fully deprecated their older v1.5 APIs which were used for some calls for additional information. When we ported these calls to the newer v2.0 API, they were returning errors which were inconsistent. 


As 2019.3 is not slated for General Release until 14th of April, we're continuing to work on resolving the matter with ConnectWise as a matter of urgency; although we cannot expedite their resolution. We have made them aware of the major impact affecting beta partners who have already moved to v2019.3


The main challenge we are facing is that the issues that presented on production, are not occurring on our test and staging environments (which are provided by ConnectWise to validate release). So there is likely some reference changes in the way the APIs function, which are not impacting our staging servers but resulted in the errors for customers using cloud versions of ConnectWise.

We have a ConnectWise Platform support ticket open #11728240 and are currently awaiting their further investigation. Please note that Platform Support is only provided M-F 8-6 EDT (US Time), so we do not expect a further update from them until Monday Evening (local time). Feel free to open a ticket with ConnectWise Support to ensure that you are kept up-to-date as the ticket / issues are identified.

We realize that this will have significant impact with end of month processes, and we're looking to determine if there are ways to address the issue of v2019.3, without breaking the system for prior versions (as was the case).


Update 2nd April 2019

We currently have updates that are in QA. These are being thoroughly tested before the green light is given to release. This is a high priority however we are taking our time to make sure there is very little (to no) impact.


We have now been told that v2019.3 General Release has been pushed back to the 17th April, 2019 (from the 14th). We expect this issue to impact customers that are on the beta program.


Update 3rd April 2019

We have re-deployed the hotfix for Wise-Sync v4.6.4.1 and Wise-Pay v1.6.4.1. This release sees the support for ConnectWise v2019.3.


We were required to port some of our interactions with the ConnectWise API from the legacy SOAP API to their REST API.


Important note for ConnectWise Customers already on v2019.3 (Beta Partners) - Wise-Sync users MUST update their ConnectWise REST API Credentials now.


Important note for ConnectWise Customers moving to v2019.3 - ConnectWise has slated general release of v2019.3 for the 17th April, 2019. Wise-Sync users must have their ConnectWise REST API Keys configured in Wise-Sync by this date. We strongly recommend configuring this at your earliest convenience.


Click here to view Wise-Sync Version Release Notes v4.6.4


Please note: There is an outstanding error with the Procurement Sync that we're working to resolve as soon as possible - Failed to get product by item 'xyz'